TelecomTest Solutions

TelecomTest Solutions TelecomTest Solutions (TTS) is a manufacturer’s representative & innovative technology solution provider to the telecommunication industry.

Being in the Telecommunications Industry, TelecomTest Solutions (TTS) is a manufacturer's representative & innovative technology solutions provider. TTS primarily focuses on delivering Communications, Test & Measurement solutions as well as Timing, Frequency and Network Synchronisation solutions to the Lab and to the Field with unmatched customer service and support. TelecomTest Solutions (TTS) is accredited to strengthen Australia and New Zealand’s Telecommunications industry through support and service verification. We partner with our customers to offer end-to-end solutions in the Lab and in the Field. Our consultants have more than a combined 30 years experience, capitalising on a solid foundation of technical expertise and skills to deliver optimal results – we provide solutions to the most unique of requirements in line with varying budgets. Supported by a strong alliance of technically proficient manufacturers that have been carefully selected, our capabilities are vast and diverse. We offer the solutions required to carry out proof-of-concept evaluations in a lab environment as well as at the edge of your network all the way to the core, at both the physical interface and into the network cloud.

NBN APPROVED: Fiber Video Inspection Probe and Tips as per NBNCo Contractors Pricing and Specifications (adheres to IEC-...
14/08/2024

NBN APPROVED: Fiber Video Inspection Probe and Tips as per NBNCo Contractors Pricing and Specifications (adheres to IEC-61300-3-35)

PASS/FAIL feature included on iOS/Android APPs

Each kit consists of:

Qty 1: EasyGet WiFi Wireless Fiber Endface Microscope and accessories: DC5V power adaptor, protective carry case and user manual
Qty 1: Pass/Fail analysis SW for IOS/Android (adheres to IEC-61300-3-35)

Qty 1: Tip universal 2.5mm/UPC-M,
Qty 1: Tip universal 1.25mm/UPCM,
Qty 1: Tip SC/UPC-F
Qty 1: Tip LC/UPC-F
Qty 1: Tip male universal 2.5mm/APC tip for APC fiber connectors incl. SC, FC, ST
Qty 1: Tip OPTITAP female SC-APC-F for OPTITAP SC/APC bulkhead

Contact us for more details

SATlink WS-6909 3.5 - Inch DVB-SandDVB-T Combo Satellite Signal Finder Meter High quality and stable performance: it's w...
14/08/2024

SATlink WS-6909 3.5 - Inch DVB-SandDVB-T Combo Satellite Signal Finder Meter

High quality and stable performance: it's with a microprocessor controller.

· 3.5" LCD color display, bigger menu window.

· Channel picture, signal strength and signal quality can be showed on LCD Screen after you set up your local DVB-S & DVB-T Parameter.

· It's with auto-protection for LNB short-circuit.

· It shows Azimuth and Elevation, CBER/VBER, S/N, signal strength and signal lock sound alarm

· AU power plug

Link to video: https://www.youtube.com/watch?v=wRr0Wx4Ed8Y

Contact us for more info or purchase

ST332B VDSL tester is multi-functional hand-held VDSL2 test instrument with small size, specially designed for xDSL line...
14/08/2024

ST332B VDSL tester is multi-functional hand-held VDSL2 test instrument with small size, specially designed for xDSL line test (xDSL include: ADSL, ADSL2, ADSL2+, READSL, VDSL2 etc) and maintenance It provides xDSL test, PPPoE dial test, DMM test, Modem emulation, line voltage indication and so on.

Product Features

Test objects: ADSL; ADSL2; ADSL2+; READSL; VDSL2
Fast Copper tests with DMM (ACV, DCV, Loop and Insulation Resistance, Capacitance, Distance)
Supports Modem emulation and simulating login to Internet
Supports ISP login (username / password) and IP Ping test (WAN PING Test, LAN PING Test)
Supports all multi-protocol, PPPoE / PPPoA (LLC or VC-MUX)
DSL Physical layer test
Modem Emulation (Replace the user Modem completely)
PPPoE Dialing (RFC1683,RFC2684,RFC2516)
PPPoA Dialing (RFC2364)
Telephone Function
DMM Test
Ping Function (WAN & LAN)
Data upload to computer and software management
Setup system parameter: backlight time, shut off automatically time without operation, press tone,
Revise PPPoE / PPPoA dial attribute, user name and password; restore factory value and so on.
Check dangerous voltage

Contact us for more details

Address

655 Collins St
Docklands, VIC
3008

Alerts

Be the first to know and let us send you an email when TelecomTest Solutions posts news and promotions. Your email address will not be used for any other purpose, and you can unsubscribe at any time.

Shortcuts

Share